Tuesday, 27 January 2009

My dad passed away today.

After about 13 years of suffering from Rheumatoid Arthritis my father passed away this morning in Auckland, New Zealand. He was a wife, farther, grand father, gardener, inventor, maker and a friend.
My father enjoying the company of my mum, wife and kids a few days ago.
Sunrise moments after my father passed away. Lake Pupuki in the foreground and Rangitoto Island in the background.

Monday, 19 January 2009

More testing with some odd results

I tried switching to speed closed loop control with some unusual results. Also to a single profile to assist testing and reduce the possability of errors by adjusting 2 profiles.

If I coast backwards, even though forward is selected it accelerates reverse. I could not test the opposite due to the slope of my driveway. If I do a perfect hand brake start, it goes forward.
Back to open loop for now. :(

I hope my VFD does not have some strange fault.

The diff has a lot of backlash so when you lift off the accelerator there is a real clunk and lurch intil the drive figures out -0 torque is being generated and lets go. I anticipate this to be less obvious at road speed.

As I think tuarn mentioned in the past, speed mode might take some getting used to.

I will try torque mode next.

Kogan Agora 'google phone' delayed

The Kogan Agora Andoroid phone has been delayed indefinatly.
http://www.kogan.com.au/blog/2009/jan/16/kogan-agora-be-delayed/

Friday, 16 January 2009

It Moves!

After quite a few months the Electro-Lux is now moving.

The speed control is like controlling the speed on a stepper motor. The throttle is very direct and it tends to shudder like a learner driver. Perhaps I just need to get used to it.

Here is a short video anyway. I will take a better one tomorrow whith no 2 stroke sound effects.

video

Thursday, 15 January 2009

VFD configuration finalised.

Thanks to Tuarn (acmotor) on the AEVA forums for all your help.

Here is my running config at the moment. I will connect the drive shaft on Sat. Wish me luck!

The related schematics are in an earlier post in case you need to make sense of the 3xx settings.

Setup 1 - Forward - Changes from default.
ID Name Value
009 Display line 2 Feedback [unit]
010 Display line 1.1 Dc link voltage
011 Display line 1.2 Reference [%]
012 Display line 1.3 Output energy
014 Local stop Disable (0) Prevents rapid deceleration.
102 Motor power 15.00
103 Motor voltage 415
105 Motor current 28.00
106 Motor nom. speed 1450
108 Stator resist 0.2641 From AMA
109 Stator react. 20.33 From AMA
113 Lo spd load comp 0
114 Hi spd load comp 0
115 Slip compensat. 0
119 High start torq. 0.5
123 Min.f. func.stop 0.1
128 Mot.therm protec Etr warning1
200 Out freq rng/rot 132 hz bothirections
205 Max. reference 132.000
206 Ramp type S2 (2) Gives better low speed control.
207 Ramp up time 1 6.00 Economy
208 Ramp down time 1 3.00 Economy
209 Ramp up time 2 4.00 Power
210 Ramp down time 2 2.00 Power
221 Torq limit motor 348.5 drive Max.
222 Torq limit gener 66.6 10kW max regeneration
227 Warn. feedb. low -4,500.000
228 Warn. feedb high 4,500.000
300 Digital input 16 Setup select LSB
301 Digital input 17 No operation
302 Digital input 18 Latched start
303 Digital input 19 No operation
305 Digital input 29 Ramp 2 (17) Power / Economy switch
306 Digital input 32 No operation
307 Digital input 33 Encoder feedback input A
314 Ai [mA] 60 funct No operation
319 Ao 42 function Fb min-max =0
320 Ao 42 puls scale 66 Speedo Cal
321 Ao 45 function Fb min-max =0
322 Ao 45 puls scale 144 Tacho Cal (Check if should be 150 = 4500/60*2)
323 Relay 1-3 funct. No operation
325 Relay 1-3 off dl 0
326 Relay 4-5 funct. No operation
329 Encoder pulses 40 Set for speed pickup
345 Enc loss timeout 0.2
409 Trip delay torq. 60 Maximum
410 Inv.fault delay 35 Maximum
411 Switch frequency 14.0 Maximum
415 Max. feedback 4,500.000 This value should be 10% higher than par. 205
416 Ref/feedb. unit Rpm (3)
445 Flying start Enable (1)
446 Switch pattern 60° avm (0)
457 Mains imbalance Warning (1)

Setup 2 - Reverse (Changes From Setup 1)
205 Max. reference 50.000
303 Digital input 19 Reversing (1)

Wednesday, 14 January 2009

The new speed sensor works.

I installed the new inductive pickup today and it works all the way to the maximum speed of just under 4000RPM.

Reverse using the '132Hz anticlockwise' setting is still a problem. In closed loop the motor revs to maximum after a few hundred RPM. I have sent the config to Danfoss support to check out.

Tuesday, 13 January 2009

Some say that talk is cheap

I say that negative torque recharges my batteries.

I am contemplating building a trip computer and feeding it from data from the VFD.

The sign of the torque figure (signed 16 bit int) is the only way to tell if the system is regenerating. I will incorporate this into the trip computer, also to activate the brake lights.

Monday, 12 January 2009

Charger input finalised

I have finished the charger input side of the system.

Electrical parts are $$$ There is over $150 in these photos.

In the ABS box there is a 10A Earth Leakage / Circuit Breaker, Relay that disables the contactors while charging and the Active and Neutral junction blocks.

There is a caravan power inlet on the outside of the tray with the earth pin filed for 10A instead of 15A.

There is enough space on the DIN rail to add a KWh later.







Friday, 9 January 2009

Phase lost and Earth Leakage trips.

Since there are a few people watching this thread, I have another problem to contend with. 

I keep getting phase lost and earth leakage trips. After a few restarts, the problem usually goes away until the next day. I have double checked all connections. The motor connections were a little loose but the problem persists. Any ideas? The trip current is 3.5mA for the VFD. I am using 10mm^2 3 core+earth, unsheileded. about 4M long. The motor was mega tested when I bought it and I will borrow one to test again.

Here are my latest schematics

I hate Visio, but here they are.

VFD Connections and cab controls


Interlocks, Circuit Breaker VFD and 12V PSU



Chargers and Batteries









Thursday, 8 January 2009

Ordered a diferent inductive speed sensor

Based on the advise here (Page 26 in PDF) for similar sensors, I need one that has a closer sensing distance.

They are quite complex devices that need more design than I anticipated.

Should arrive tomorrow to try on the weekend.

If this fails, I will need to make the drive flange 20 tooth rather than 40.

Wednesday, 7 January 2009

Tacho Works now :)

Using the tip provided by Johny directing me to http://www.kolumbus.fi/juha.niinikoski/Tacho/Tacho.htm I tried connecting the tacho to the 24v frequency output from the VFD via a 1k resistor and it works a treat!

Useful thinks I can display are:
RPM
Torque
Power
Throttle position


Tuesday, 6 January 2009

Tacho clues

Thanks to Johny on the AEVA forums this provides a clue. http://www.kolumbus.fi/juha.niinikoski/Tacho/Tacho.htm

Based on this I should be able to hook the tacho up to the VFD via a 1k Resistor. Will try again tomorrow.

The speedo works, no so the tacho

I got the speedo working today. It has an optocoupler to interface the frequency output from the VFD to the 12 volt active low of the speedo. See images below.

I cant for the life of me get the tacho going. From checking the wiring when I removed the ignition, there is a 1k resistor from the low (switched) side of the coil to the tacho. I have tried a high side opto and low side but no success yet. I really want the taco going so I can use it to read out RPM, torque, current, voltage or whatever parameter I choose.






Monday, 5 January 2009

The heater is a winner

I tested the heater today (after replacing the fuses in my multimeter. Why do they specify 630ma?)

Here are the stats. All reading are in Deg C

Voltage after test: 656V
Ambient temp: 28C
Fan on Low: 45C 
Fan on 2: 35C
Fan on 3: 39C
Fan on High: 32C

Minimum variance from ambient = 4C - fan on high
Maximum variance from ambient = 17C - Fan on low.

I am happy with that. After I get it the ute road legal, I will look at reverse cycle air conditioning.

The speed sensor problem is unresolved. I will probably bevel the teeth on the drive flange.

Sunday, 4 January 2009

Reverse is sorted out with a little diode logic :). Speed sensor still not working.

I sorted out reverse with a little diode logic to make my forward / reverse switch work how I want it. The switch is a rotary switch with 3 positions. Forward / Neutral / Reverse.

Start is initiated by turning the key. This provides an interlock so the motor wont start if the switch is knocked accidentally.

I still have some problems with the speed sensor. It is dropping pulses at high RPM. It is a 3kHz unit but something is wrong with it. The max Hz of the sensor should be 4000RPM x 40 teeth on pickup = 2666Hz

See following oscilloscope photos.


Output at 30Hz. Nice and square with a bit of wobble.


Sensor output at 100Hz. Lots of dropped pulses.


Friday, 2 January 2009

Whats left?

In no particular order
  1. Figure out why reverse doesn't work correctly
  2. Install speed pickup for closed loop control
  3. Fit drive shaft
  4. Organise the tray cover from Geoff O'Toole
  5. Permanently wire the charger mains side and relay interlock
  6. Replace small blue emergency off switch with a slightly larger red one
  7. Finish touch up painting and clear coat.
  8. There is bound to be something I have missed.

It Lives!

After  a few busy days, the motor is finally rotating under battery power with the drive shaft (tail shaft) disconnected! Quite a milestone. It is running on variable speed open loop at the moment.

For some reason the motor wont reverse, it just pulses at about 100RPM.
Forward works perfectly.

I will add the speed pickup tomorrow. Hopefully that will sort it out!


When testing, ensure GOOD help is at hand.
Thankfully none of the safety measures were required :)



The team. Tim for his safety checks, Noel for a helping hand these last few days, my wife and of course myself in the grey shirt.